Graent.Hu 的博客

新浪微薄腾讯微薄

最新碎语:最近感觉有些迷茫,怎么办~

您的位置:Graent.Hu 的博客 >PHP编程> 转:composer require安装指定版本

转:composer require安装指定版本

版本符号说明

#最新版 
* 
# 大于等于1.0的最高版本 
>=1.0
#大于等于1.0且小于2.0的最高版本 
>=1.0 <2.0
#1.0至2.0之间的最高版本 
1.0 - 2.0
#>=1.0且<1.1的最高版本 
1.0.* 
#>=1.2且<2.0的最高版本 
~1.2 
#>=1.2.3且<1.3.0最高版本 
~1.2.3
#>=1.2.3且<2.0.0的最高版本
^1.2.3

安装依赖包

composer require xxx/xxx:1.0.x
composer require xxx/xxx=1.0.x@dev

两种安装方式。第二种加个 @dev 标志意思是说可以安装开发版本,因为composer 默认只取 stable 版本

一般情况下依赖包里的composer.json里有个字段 minimum-stability是用来标志此版本是什么版本的值一般有 devalphabetaRCstable,默认是 stable  

安装开发依赖包

什么意思呢?,意思就是这些依赖包是开发这个项目时为啦测试一些东西而使用的,跟功能没有关系,这样别人下载后不会安装这些库,使用方法如下

composer require-dev xxx/xxx

我的微信:graent_hu

欢迎扫码加我和微信好友,有什么问题我们可以一起探讨,有什么需要也随时欢迎发消息给我~

转载请注明出处:

本文标题:转:composer require安装指定版本

本文链接:https://www.wlyc.cn/post-175.html

发表评论

路人甲 表情
看不清楚?点图切换